Release User sessions stuck on a hung XenApp Server VDA without rebooting

Release User sessions stuck on a hung XenApp Server VDA without rebooting

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Article ID: CTX217246

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Updated On:

Description

User sessions stuck on a hung XenApp Server VDA and the only way to allow users to connect to new sessions is to reboot the XenApp Server VDA.

Resolution

If you want to allow users with sessions on the hung server to obtain new ones on other VDAs, you can use the PowerShell SDK to 'hide' those sessions:

Asnp citrix*
Get-BrokerSession -MachineName <Domain\VDAHostname> | Set-BrokerSession -Hidden:$true

If the hung VDA still appears as registered you'll also want to put it into maintenance mode to prevent the DDCs from ever attempting to start new sessions on it.

***Caution should be paid to the possibility of profile corruption since the user sessions are not actually being logged off of the Hung server. This command simply relinquishes the sessions from the XenDesktop perspective, so that new user sessions can begin on a different VDA.

Note: For cloud use the remote PowerShell SDK

Problem Cause

User sessions stuck on a hung XenApp Server VDA

Issue/Introduction

Release User sessions stuck on a hung XenApp Servre VDA without rebooting