When Launching an Application Internally via Netscaler User Receives Error: "Cannot Connect To The Citrix XenApp Server. There Is No Citrix XenApp Server Configured On The Specified Address"
book
Article ID: CTX217065
calendar_today
Updated On:
Description
With a NetScaler Gateway and StoreFront setup, while launching application users get following or similar errors:
- "Unable to launch your application. Contact your help desk with the following information. Cannot connect to the Citrix XenApp server. There is no Citrix XenApp server configured on the specified address"
ICA file which gets downloaded on client machine will have internal Xenapp Sevrer's IP address instead of the STA ticket as highlighted below:
Example of ICA File:
[ApplicationServers]
App123=
[App123]
Address=1.2.10.200:1494
AutologonAllowed=ON
BrowserProtocol=HTTPonTCP
CGPAddress=*:2598
ClearPassword=E6954E0E16B68B
ClientAudio=On
DesiredColor=8
DesiredHRES=0
DesiredVRES=0
Resolution
To resolve this issue, you need to modify the web.config file for the store(s) on the Storefront Server(s).
- Navigate to: "C:\inetpub\wwwroot\Citrix\Store" (Change Store to the name of the relevant Store)
- Open the web.config file for the Store and remove the Optimal Gateway configuration from the file

Just leave the first line with a space and a slash as shown below
Before: <optimalGatewayForFarmsCollection> ***Delete this line***
<optimalGatewayForFarms enabledOnDirectAccess="true">
<farms>
<farm name="farmname" />
</farms>
<optimalGateway key="_" name="deploymentname" stasUseLoadBalancing="{true | false}"
stasBypassDuration="hh:mm:ss" enableSessionReliability="{true | false}"
useTwoTickets="{true | false}">
<hostnames>
<add hostname="appliancefqdn:port" />
</hostnames>
<staUrls>
<add staUrl="https://stapath/scripts/ctxsta.dll" />
</staUrls>
</optimalGateway>
</optimalGatewayForFarms>
<optimalGatewayForFarms>
...
</optimalGatewayForFarms>
</optimalGatewayForFarmsCollection> After changes:<optimalGatewayForFarmsCollection />
<resource…etc etc…
Problem Cause
This is a known issue with Storefront 3.0.1+.
By default if the Optimal Gateway feature is enabled on Storefront, it will generate an internal ICA file with IP address of internal XenApp server instead of STA ID which will cause launch failures through Netscaler Gateway
Was this article helpful?
thumb_up
Yes
thumb_down
No