Published applications may fail to launch when Dell remote scan is installed on VDA

Published applications may fail to launch when Dell remote scan is installed on VDA

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Article ID: CTX216751

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Updated On:

Description

Users cannot launch applications after installing Dell remote scan software in the VDA.
Application tries to launch, however after the loading bar is complete and disappears. The application does not start, however, the session was created and you can verify this on the VDA by opening the task manager under the user session, you can see that application was launched successfully (in screenshot excel was used)

User-added image

On VDA using resource monitor under cpu - modules, there were no Citrix dll's loaded for the process, in this example notepad is the executable and mfaphook64.dll is the dll loaded, so basically if mfaphook64 is not loaded the below registry keys need to be added.

User-added image

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Verify whether the following registry keys exist on VDA.
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows
Name:AppInit_dlls
Type: REG_SZ
Value: mfaphook.dll,mfaphook64.dll

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
Name:AppInit_dlls
Type: REG_SZ
Value: mfaphook.dll,mfaphook64.dll

Problem Cause

Dell software was blocking Citrix hook dlls