Citrix XenApp is Unable to Retrieve the License Server lLocation

Citrix XenApp is Unable to Retrieve the License Server lLocation

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Article ID: CTX216615

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Updated On:

Description

XenApp 6.5 - Unable to retrieve the license server location. Getting the following error message on a XenApp server at logon: "Citrix XenApp is unable to retrieve the license server location. Check to see if the Citrix Independent Management Architecture service is running without error. If necessary, set the license server location in the Citrix Group Policy."

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Export the IMA registry key under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix from a working server and import it on the server affected.

Restart the IMA service and reboot the server.

Problem Cause

Registry key "IMA" missing under HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Citrix\.
IMA policies not applying properly on the server.
 

Issue/Introduction

"Citrix XenApp is unable to retrieve the license server location. Check to see if the Citrix Independent Management Architecture service is running without error. If necessary, set the license server location in the Citrix Group Policy."

Additional Information

http://support.citrix.com/article/CTX134961 - XenApp Policies not Applying Correctly

http://discussions.citrix.com/topic/300211-citrix-xenapp-is-unable-to-retrieve-the-license-server-location/