Citrix Desktop Service service failing to start with error 1053
book
Article ID: CTX216546
calendar_today
Updated On:
Description
Restarting the Citrix Desktop Service fails with error 1053 on event viewer:

Event ID 1035 on the event viewer:

Environment
Citrix is not responsible for and does not endorse or accept any responsibility for the contents or your use of these third party Web sites. Citrix is providing these links to you only as a convenience, and the inclusion of any link does not imply endorsement by Citrix of the linked Web site. It is your responsibility to take precautions to ensure that whatever Web site you use is free of viruses or other harmful items.
Resolution
1. Check permission to C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\Machine.config

2. Permissions should be as below:
-ALL APPLICATION PACKAGES:
-Read & Execute
-Read
-SYSTEM:
.Full Control
.Modify
.Read & Execute
.Read
.Write
-Administrator (VDAhostname\Administrators)
.Full Control
.Modify
.Read & Execute
.Read
.Write
-Users (VDAhostname\Users)
.Read & Execute
.Read
3. Check permissions under the following location too:
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\Machine.config
4. Set the permissions as instructed in both locations.
5. Check the 'Log on' tab on Citrix Desktop Service Properties and make sure 'Network Service is used.

Problem Cause
Application install changed permission under folder C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Config\Machine.config and C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\Machine.config
Issue/Introduction
Desktop Service failing to start with error 1053 aster installing application
Additional Information
- The Citrix Desktop Service on a Virtual Desktop Agent Fails to Start - http://support.citrix.com/article/CTX119421
Was this article helpful?
thumb_up
Yes
thumb_down
No