When Accessing VPN, Address Gets Stuck At URL: https://<external FQDN:8080/vpns/services.html
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Article ID: CTX216510
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Updated On:
Description
When a client using web browser connects to the VPN via Netscaler, the web page gets stuck on https://<Gateway URL>:8080/vpns/services.html
Removing :8080 from the URL allows the homepage redirection to continue.
Resolution
Modify the f_ndisagent file under the /var/netscaler/gui/vpns folder.
From
window.location = "http://" + window.location.hostname + ":8080/vpns/services.html" ;
To
window.location = "https://" + window.location.hostname + "/vpns/services.html";
After above change the plugin doesn’t try to handle services.html request, so request goes directly to Gateway server.
(changes do not survive a reboot)
Also Sometimes The file f_ndisagent is picked from different location /netscaler/gui/vpns
If you see that the file under location /var/netscaler/gui/vpns already edited and does not have 8080 anymore and still issue occurs then Go ahead and edit the file under /netscaler/gui/vpns
Problem Cause
In Netscaler Release 10.5, when a client VPN plugin attempts to establish the connection, it will handle the initial request for the services.html page, which, by design is an HTTP request on port 8080. The services.html page will then redirect to either the portal homepage or to the configured homepage in the session profile.
If the VPN connection is taking longer than expected, the plugin will not be able to send the request over the VPN on port 443 and so will result in the page stuck on :8080/vpns/services.html.
Additional Information
Starting with NetScaler 11.0 Release, portal pages use HTTPS without port 8080 for homepage redirection. Therefore, upgrading to 11.0 is an alternative to the above procedure.
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