XenDesktop 7.x - Unable to unlock the VDA using Ctrl + Alt + Delete sequence inside an ICA session
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Article ID: CTX216131
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Description
When users lock their ICA sessions and then try to unlock the session using Ctrl + Alt + Delete sequence, the session does not get unlocked. In the absence of Desktop Viewer (Full Screen Session) this can force the user to disconnect and reconnect the session or reboot their VDA.
Resolution
By default ICA Client does not pass the keyboard shortcuts to the remote machine. This can be enabled through local group policy on the client. The latest receiver is shipped with Receiver.ADMX and Receiver.ADML files stored under C:\Program Files (x86)\Citrix\ICA Client\Configuration (Or C:\Program Files\Citrix\ICA Client\Configuration) folder. Copy Receiver.Admx to C:\Windows\PolicyDefinitions folder and Receiver.Adml to C:\Windows\PolicyDefinitions\en-US folder.
1. After copying the files open local group policy management console ( Start > Run > Gpedit.msc ) and navigate to the following path:
Local Computer Policy > Computer Configuration > Administrative Templates > Citrix Components > Citrix Receiver > User Experience
2. Double-click Keyboard Shortcuts from the right hand side and set it to Enabled. In the bottom pane you can see the various shortcuts that will be enabled. You can modify the shortcuts as per requirement and click Ok,
3. Go to command prompt and run gpupdate /force to apply the policy changes.
4. Restart the receiver and test the shortcut.
Problem Cause
Incorrect client configuration.
Issue/Introduction
When users lock their ICA sessions and then try to unlock the session using Ctrl + Alt + Delete sequence, the session does not get unlocked. In the absence of Desktop Viewer (Full Screen Session) this can force the user to disconnect and reconnect the session or reboot their VDA.
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