Error: "Failure - TCP connection successful, but application timed out" on NetScaler

Error: "Failure - TCP connection successful, but application timed out" on NetScaler

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Article ID: CTX215481

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Updated On:

Description

NetScaler services went down for a few seconds.

The following is seen in the newnslog at the time of the issue:
"Failure- TCP connection successful, but application timed out"

Resolution

"TCP connection successful, but application timed out" - This means the server is accepting connections, but not actually serving pages (at least before the probe timeout).

  • If this is an occasional failure then we need to check at the server side to confirm if there were any application failures at the time of the monitor failure.
  • If this monitor has never worked then we need to confirm if the parameter that the server is looking for is configured correctly in the Netscaler monitor bound to that service.

You can use the Newnslogs and nslogs on the Netscaler Log section to view the events which occured during the timeout .

Reference Article : https://support.citrix.com/article/CTX113341 --How to Obtain Performance Statistics and Event Logs from NetScaler

Problem Cause

The issue can be caused due to some issue on the server side or the parameters specified in monitor bound to that service.

Issue/Introduction

This article talks about the issue where Netscaler service under Load balancing went down and to find the root cause for the same.

Additional Information

https://support.citrix.com/article/CTX113341 --How to Obtain Performance Statistics and Event Logs from NetScaler

https://support.citrix.com/article/CTX109304 --Data Collection Procedure to Troubleshoot NetScaler Related Issues