Error: You Cannot Access this Session Because no License are Available

Error: You Cannot Access this Session Because no License are Available

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Article ID: CTX215192

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Updated On:

Description

Launching application results in "Error: You Cannot Access this Session Because no License are Available"

Check in Licensing Server - under C:\Program Files(x86)\Citrix\Licensing\Myfiles - if the file 'Citrix_startup.lic' is missing.

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

  • Check if the startup license is present under C:\Program Files(x86)\Citrix\Licensing\Myfiles
  • Import the file under C:\Program Files(x86)\Citrix\Licensing\Myfiles
  • Restart the Citrix Licensing Service.
  • On Delivery controller server - restart the Citrix Broker service
  • Try launching the application/desktop now, it will work fine.

Problem Cause

Citrix_startup.lic file is missing.