Topaz Signature com port Redirection Works The First Time, Subsequent Logins Fail Requiring a Reboot

Topaz Signature com port Redirection Works The First Time, Subsequent Logins Fail Requiring a Reboot

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Article ID: CTX214430

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Updated On:

Description

Experiencing issue with com port redirection in XenApp 7.6 shared desktop. COM port redirection appears to work the first time but subsequent logins fail requiring a reboot of the server.

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

Solution 1 - Binary Fix

The issue seems to be related to an available Binary fix: 

1. Replace rpm.dll under C:\Program Files (x86)\Citrix\System32\ of TSVDA with the private binary; 
2. Reboot the VDA to make the private work; 
3. Verify if this issue is corrected. 

Note: Contact Citrix Technical Support to request the private binary fix.

Solution 2 - XenApp 7.8

This private fix is publicly available with XenApp 7.8. Refer to Citrix Documentation - Fixed issues in XenApp 7.8 and XenDesktop 7.8.


Problem Cause

RootCause: The COM connection of previous session is not unbind on  CStack::DisconnectNotify(), because the stack has been disconnected before CStack::DisconnectNotify(). This issue should be caused by fix of BUG0487797.

Issue/Introduction

Experiencing issue with com port redirection in XenApp 7.6 shared desktop. COM port redirection appears to work the first time but subsequent logins fail requiring a reboot of the server.