Session Recording not Working on Server OS; Event ID 1009

Session Recording not Working on Server OS; Event ID 1009

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Article ID: CTX214364

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Updated On:

Description

Attempting to record session for Server OS sessions is unsuccessful. Client's event viewer states the following error:

Event ID 1009 - Exception caught while obtaining session or running record policy query.

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Resolution

On the Session Recording Client Properties:

  1. Set the MSMQ protocol to TCP
  2. Set the Session Recording Broker to HTTPS on Custom Port 443

Problem Cause

MSMQ was set to HTTPS as well but it hadn't been configured for it . To configure MSMQ to use HTTPS customer needs to follow the configuration:

http://support.citrix.com/content/dam/supportWS/kA460000000CnKLCA0/Configuring_Security_Features.pdf

Issue/Introduction

​-Event ID 1009 - Exception caught while obtaining session or running record policy query.