Black Screen While Launching Desktop - MFAHook64 Not Loading Properly

Black Screen While Launching Desktop - MFAHook64 Not Loading Properly

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Article ID: CTX213541

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Description

Users are getting black screen when launching a desktop through ICA session. When running Process Explorer on the PICAUserAgent process we noticed the MFAHOOK64.DLL is not loaded.

Resolution

Modify the path for Mfaphook from HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows "AppInit_DLLs"="C:\PROGRA~2\Citrix\System32\mfaphook64.dll" TO: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows "AppInit_DLLs"="mfaphook64.dll"

*Note. This key has been removed in XenDesktop 7.9 onwards.


Problem Cause

The path for the mfahook64.dll couldn't be resolved.

Issue/Introduction

Users are getting black screen when launching a Desktop through ICA session - when running Process Explorer on the PICAUserAgent process we noticed the MFAHOOK64.DLL is not loaded