Citrix UPS Printers are not visible via Control Panel, Devices And Printers
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Article ID: CTX213540
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Description
Only printers connected by the Citrix Universal Print Server are affected (printers which use Citrix universal print server print provider, upprov.dll)
There are no errors associated with this issue as the printers are actually connected for the user they are just not visible to the user via Control Panel, Devices And Printers.
Users can view and use their printers as normal in applications.
NOTES:
This does not affect Citrix auto-created printers (client printers redirected into ICA session)
This may be seen with other 3rd party Printing solutions, which implement their own print providers
Resolution
This is an known issue with printers provided by Citrix Universal Printer server on windows operating systems Windows Server 2019, Windows Server 2016, Windows 10, Windows Server 2012r2, Windows Server 2012.
Citrix is working with Microsoft to correct this interaction between Microsoft operating systems and Citrix universal print server print provider.
Citrix Documentation:This issue has been documented in our XenApp/XenDesktop documentation since 7.5
- Universal Print Server printers selected in the virtual desktop do not appear in the Devices and Printers window in Windows Control Panel. However, when users are working in applications, they can print using those printers. This issue occurs only on Windows Server 2012, Windows 2012 R2 , Windows 10 and Windows 8 platforms. [#335153]
Microsoft Documentation:The Device Setup Manager service is discussed in the following article from Microsoft it applies to both Windows 8 and Windows 2012.
Device setup user experience in Windows 8Microsoft released a hotfix for server 2012r2 which partially addressed some issues with 3rd party print provider visibility in newer windows releases.
However this was not a complete solution, and printers provided by Citrix Universal Print Server remained not visible.
https://support.microsoft.com/en-us/help/2966038/printer-managed-by-custom-print-providers-is-not-visible-in-devices-an
Problem Cause
Issue with the Windows Operating System and printers being managed by 3rd party print providers.
Issue/Introduction
When using the Citrix Universal Print Server solution for network printers users may not be able to see these printers from applications hosted by Windows 2012 or Windows 2012 R2 servers.
If the user also tries to look for them from Windows 2012 or Windows 2012 R2 "Devices and Printers" section they are also missing from there yet no errors are logged that the printers were not connected.
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