Unable to launch applications externally through Netscaler Gateway, getting internal server IP address in ICA file

Unable to launch applications externally through Netscaler Gateway, getting internal server IP address in ICA file

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Article ID: CTX213383

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Updated On:

Description

Unable to launch application externally through Netscaler Gateway and when checking further we see that we are getting internal server IP address in ICA file rather than "Gateway FQDN:443".

Resolution

Follow the below troubleshooting steps to resolve the issue:
  1. After launching the Application/desktop check in the ICA file that is downloaded on client machine if it has internal server IP address rather than "gateway FQDN:443" information. 
  2. In ICA file look for the below parameter and confirm if that has Netscaler Gateway FQDN:443 as specified on storefront server in Netscaler Gateway settings: SSLProxyHost=gateway-fqdn:443
  3. Confirm on Netscaler Gateway the STA server is added under vserver or globally, similar to what you have specified on Storefront Gateway settings.(In this case the STA's were missing from Gateway side but were added on Storefront side.)
  4. Once STAs are added on Netscaler Gatewa,y App launch should work fine.

Problem Cause

STA's were missing on Netscaler Gateway