Error: "Guided Access Application Unavailable. Please Contact Your Administrator" on XenMobile Enrolled iOS Device

Error: "Guided Access Application Unavailable. Please Contact Your Administrator" on XenMobile Enrolled iOS Device

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Article ID: CTX213298

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Updated On:

Description

A XenMobile enrolled iOS device will show a "Guided Access App Unavailable. Please Contact Your Administrator.” error on screen and the device may appear to be frozen or locked.

Resolution

When this error occurs, the device will likely appear frozen, a few solutions are available:

  1. Push an AppLock Removal policy to the device to remove the lock mode, thus removing the error.
  2. Issue a selective or full wipe to the affected device to remove the AppLock policy.
It is important to note that this error is not caused by XenMobile, but rather, the series of events of locking an iOS device into an app which is not installed. If you encounter this error, please check your deployment policies to ensure the needed app is installed before pushing an AppLock policy.

Problem Cause

This issue occurs when a AppLock policy has been pushed to a device which does not have the app installed for the corresponding AppLock policy. In essence, the device is trying to lock into a non-existent app and the device will show this error as a result.

Issue/Introduction

A XenMobile enrolled iOS device will show a "Guided Access App Unavailable. Please Contact Your Administrator.” error on screen and the device may appear to be frozen or locked.