Slow Logon with a Black Screen in XenDesktop Server VDA.

Slow Logon with a Black Screen in XenDesktop Server VDA.

book

Article ID: CTX212905

calendar_today

Updated On:

Description

  • Logon to XenDesktop Server  VDA with OS Windows 2012 R2 is very slow.
  • Black screen displayed upto 240 Seconds.
  • When the logon is completed everything work fine.
  • Remote Desktop and console users experience a slow logon with a blank screen before the desktop is eventually rendered.
  • Longer logon times may directly correspond to the number of desktop shortcuts that are defined in the user’s profile.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Complete the following steps:

  1. Create a New Group Policy Object (GPO):

    • In the GPMC, right-click on the Organizational Unit (OU) where you want to apply the policy.
    • Select Create a GPO in this domain, and Link it here.
    • Name the GPO (e.g., "Delete Registry Values on Logoff").
  2. Edit the GPO:

    • Right-click on the newly created GPO and select Edit.
  3. Navigate to the Registry Settings:

    • In the Group Policy Management Editor, go to:
      User Configuration -> Preferences -> Windows Settings -> Registry
  4. Add a New Registry Item:

    • Right-click on Registry, select New, and then choose Registry Item.
  5. Configure the Registry Item:

    • Action: Select Delete.
    • Hive: Choose HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\UFH\SHC

After the profile has been cleaned you can update the UPM registry exclusions to include this key to ensure the content of this key is no longer synched back to the UPM store.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\UFH from the registry settings


Problem Cause

Procmon shows that affected computers are busy accessing the following registry key:

HKEY_USERS\S-1-5-21-xxxxxxx\Software\Microsoft\Windows\CurrentVersion\UFH\SHC

(or HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\UFH\SHC)

In the below screenshot, we could see that Explorer.exe has spent 161 seconds performing RegDeleteValue operation on this regkey.