Citrix Receiver Error "Unable To Login" When Connecting To StoreFront With SSON Enabled

Citrix Receiver Error "Unable To Login" When Connecting To StoreFront With SSON Enabled

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Article ID: CTX210124

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company's Help Desk/IT support team and can refer to CTX297149 for more information.

 

When users attempt to run an application from Citrix Receiver they are presented with an error message "Unable to Login".
The user is connecting through a Citrix StoreFront Website with Pass-Through Authentication (SSON) enabled.

Resolution

 logonMethod in Citrix StoreFront's configuration file (web.config) was not set correctly to allow Pass-Through Authentication (SSON).

Important: In multiple server deployments, use only one server at a time to make changes to the configuration of the server group. Ensure that the Citrix StoreFront management console is not running on any of the other servers in the deployment. Once complete, propagate your configuration changes to the server group so that the other servers in the deployment are updated.
  1. Use a text editor to open the web.config file for the store, which is typically located in the C:\inetpub\wwwroot\Citrix\storename\ directory, where storename is the name specified for the store when it was created.
  2. Locate the following element in the file.
    <... logonMethod= ... >
  3. Change or make sure the value of logonMethod is set sson.
  4. So it reads <... logonMethod="sson" ... >

 

 

Problem Cause

 logonMethod in Citrix StoreFront's configuration file (web.config) was not set correctly to allow Pass-Through Authentication (SSON).
 

Issue/Introduction

When StoreFront, Citrix receiver, and Pass-Through Authentication (SSON) is configured users may receive "Unable to Login" error when launching applications.