XenDesktop Director: Unable to retrieve data when Director is installed on any machine that isn't DDC

XenDesktop Director: Unable to retrieve data when Director is installed on any machine that isn't DDC

book

Article ID: CTX208502

calendar_today

Updated On:

Description

Director on separate Server cannot retrieve data from Controller.

In CDF traces or wiresharks you will see HTTP 400 Bad request.

Resolution

Reduce the number of AD groups for the admin logged in.

Problem Cause

Director cannot retrieve data when installed on a machine other than the DDC, Seeing HTTP 400 bad request in CDF traces.

Additional Information

Additional Troubleshooting:
 

http://blogs.technet.com/b/sp/archive/2013/05/29/http-400-bad-request-request-header-too-long-error-in-internet-information-services-iis.aspx

http://www.iis.net/learn/troubleshoot/diagnosing-http-errors/troubleshooting-http-400-errors-in-iis

https://support.microsoft.com/en-us/kb/2020943

 

Download : Kerberos Ticket Utility http://www.microsoft.com/en-us/download/details.aspx?DisplayLang=en&id=1448

Run tokensz.exe /compute_tokensize /user:xxaffecteduseraccountxx /domain:domainname.full /password:accountpassword

Verify the max user token is in the range of the MaxTokenSize for the server

If it is over increase token in HKLM\system\currentcontrolset\control\Lsa\Kerberos\Parameters MaxTokenSize Reg_Dword Decimal 48000

 

 

Value name: MaxTokenSize

Data type: REG_DWORD

Radix: Decimal

Value data: 48000

 

 

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\HTTP\Parameters

 

Name: MaxFieldLength

Value Type: DWORD

Value Data: 65534

 

Name: MaxRequestBytes

Value Type: DWORD

Value Data: 16777216