Taskbar preview and Window peek does not function correctly on published apps

Taskbar preview and Window peek does not function correctly on published apps

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Article ID: CTX208020

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Updated On:

Description

In an installation of XenDesktop/XenApp 7.6 Enterprise, we see that on most of the clients the Taskbar Preview and the Windows Peek full screen preview of a minimized published application is not working correctly.

It seems that depending on the number of monitors connected, we either get no preview content at all, or in case we use 1 monitor we get a preview which contains vertical stripes.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Dynamic preview for multi monitors are disabled by default; this can be enabled by using below registry:
For 32 bit Operating System  
Registry Path : HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Seamless Windows
Name: EnablePreviewForMultiMonitor
Type: REG_SZ
Data: True

For 64 bit Operating System
Registry Path : HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Seamless Windows
Name: EnablePreviewForMultiMonitor
Type: REG_SZ
Data: True

OR

In the default.ica file for the Web Interface or StoreFront, in the [WFClient] section, add the entry "EnablePreviewForMultiMonitor=TRUE".


Problem Cause

Dynamic preview for multi monitors is disabled by default.

Issue/Introduction

In a installation of XenDesktop/XenApp 7.6 Enterprise we see that on most of the clients (different Dell workstations) the Taksbar Preview and the Windows Peek full screen preview of a minimized published application is not working correctly.

Additional Information

http://docs.citrix.com/en-us/receiver/windows/4-3/receiver-windows-43-about/receiver-for-windows-4-3-fixed-issues.html