Alt+Tab Does Not Pass Through the VDI in ICA Session

Alt+Tab Does Not Pass Through the VDI in ICA Session

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Article ID: CTX207943

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Updated On:

Description

When pressing Alt+Tab while on a VDI in ICA session Full Screen, the apps show up from the endpoint and not from the VDI.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

To resolve this issue change the following registry key on the client machine:

32-bit OS:
Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard
Type: REG_SZ
Name: TransparentKeyPassthrough
Value: Remote

64-bit OS:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Keyboard
Type: REG_SZ
Name: TransparentKeyPassthrough
Value: Remote
 


Problem Cause

Transparent key was not passing through.

Issue/Introduction

When pressing Alt+Tab while on a VDI in ICA session Full Screen, the apps show up from the endpoint and not from the VDI.