Getting error "An error occurred, Connection lost..." when accessing Weblink Qlik sense via Secure Web
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Article ID: CTX206986
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Updated On:
Description
When accessing Weblink Qlik sense via Secure Web users are getting the following error:

Resolution
We took nstrace on Netscaler and found that netscaler is doing the RESET to the client with TCP RESET code 9872
Just filter the nstrace with client and Gateway vserver IP to see this communication

We further checked nstrace and found the client is using websockets in the http requests:
To establish a WebSocket connection, the client sends a WebSocket handshake request, for which the server returns a WebSocket handshake responseLook for following header in the GET request from client that confirms client sends websocket handshake request:
Upgrade: websocket
Connection: Upgrade
Origin: http://x.x.x.test.com
Cookie: X-Qlik-Session=abc950f0-7c9e-48b1-9ea5-24e9e007e65a
Pragma: no-cache
Cache-Control: no-cache
Sec-WebSocket-Key: LZAuhEkYLcWnRNbuXwzz6w==
Sec-WebSocket-Version: 13
Sec-WebSocket-Extensions: x-webkit-deflate-frame
TCP Reset code 9872 means
"If websocket is not enabled on the http profile we reset the connection with this window size"
Recommended the customer to enable "Websocket Connection" in default http profile or by creating a new http profile and enabling that option. Then bind the new http profile to Netscaler Gateway vserver.
Problem Cause
As the http request was using websocket rendering and Websocket connections are disabled by default on Netscaler HTTP profile so that caused this issue.
Issue/Introduction
Users from Secure Web getting error "Connection lost...." when accessing it through Netscaler Gateway
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