Virtual keyboard (touch keyboard) does not open when touching icon on Windows task bar.

Virtual keyboard (touch keyboard) does not open when touching icon on Windows task bar.

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Article ID: CTX206957

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Updated On:

Description

Virtual keyboard (touch keyboard) does not open when touching icon on Windows task bar in Server VDA session.

TouchKeyboard

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Add the following Registry Setting on VDA Server to enable touch keyboard in Server VDA session.

KEY:HKLM\SOFTWARE\Citrix\MobileDesktop
Value Name:AllowInSessionKeyboard
Value Type:DWORD
Value:0x1

Problem Cause

This is by design. The touch keyboard is disabled for mobile Receiver clients by default.