Authentication Prompt Not Honoring Inactivity/Session Timeout Values on XenMobile
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Article ID: CTX206306
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Updated On:
Description
Authentication prompt is not honoring inactivity timeout value (XenMobile 9.0) or the session timeout value specified (XenMobile 10.0).
Resolution
For XenMobile 9.0
- Log on to AppController Console (https://AppCFQDN:4443/ControlPoint).
- Configure Inactivity timer for 900 minutes orĀ greater (15+ Hours).
- Re-enroll device for this newly configured value to reflect.
For XenMobile 10.0
Adjust the session timeout value on the NetScaler. The NetScaler Gateway Session Profile controls the lifetime of the microVPN session.
When the mobile device connects to the NetScaler, Secure Hub (or Receiver) tries to establish a TLS session with the NetScaler. This connection provides an authN token from the NetScaler to the mobile device when the user has successfully authenticated. The life of the authN token is managed by the Session Timeout setting. The following screen shot shows
NetScaler Management Console >
Configure NetScaler Gateway Session Profile >
Session Time-out(mins).

Session Time-out setting
In this example, if the NetScaler has not seen any network traffic for more than 30 minutes, the NetScaler flushes that session from its memory. Therefore, the next time the device tries to establish a microVPN TLS session, the NetScaler will have no record of the session token that is provided by Secure Hub (or Receiver) and the user is presented with an authentication prompt. Once the session times out for the user, they' will be forced to authenticate explicitly.
Problem Cause
Dependency of session timeout on the Netscaler rather than just XMS sever properties.
Issue/Introduction
Authentication prompt is not honoring inactivity timeout value (XenMobile 9.0) or the session timeout value specified (XenMobile 10.0).
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