Web Cams Not Working Through Published Desktop OS Session | Being Redirected As Optimized USB

Web Cams Not Working Through Published Desktop OS Session | Being Redirected As Optimized USB

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Article ID: CTX206109

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Description

The End-Users are unable to use the Web Cam through a Published Desktop OS session launched using Workspace App (USB Device Being Redirected As Optimized USB)

Resolution

  • Let's take the PID & VID of the USB Web-Cam that is being used: https://www.synology.com/en-global/knowledgebase/DSM/tutorial/Compatibility_Peripherals/How_do_I_check_the_PID_VID_of_my_USB_device
  • Through Citrix Studio, create a Policy using the following setting to assign it to AD Object or Delivery Group needed > Client USB Device Redirection: Allowed
  • From the endpoint device using Workspace App, the following Sub-Key with the DWORD named "AutoRedirect" must be created in "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\GenericUSB\Devices" > VIDxxxx PIDxxxx 
  • Then, go to "ICA session Windows > Preferences > Connections > Generic USB Devices" and check the option "When a session starts, connect devices automatically"
  • Now, the Web Cam must work through the Published Desktop OS session.
 

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Problem Cause

USB Device was being redirected Optimized first by design. 

Issue/Introduction

How to force Generic USB instead of Optimized