PVS Image Not Able to Get DHCP Address, Group Policies Not Applying

PVS Image Not Able to Get DHCP Address, Group Policies Not Applying

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Article ID: CTX206069

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Updated On:

Description

Event ID 5719 is logged when you start a Domain Member that is a PVS target 

Event Type: Error Event Source: NETLOGON Event Category: None Event ID: 5719Date: DateTime: TimeUser: N/A Computer: ServerDescription:No Domain Controller is available for domain <domain name> due to the following: There are currently no logon servers available to service the logon request. Make sure that the computer is connected to the network and try again. If the problem persists, contact your domain administrator.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Complete these steps to prep the master every time a new vDisk or version is being created:

  1. Create new version.

  2. Boot master target from this version in maintenance mode.

  3. Release IP address for NIC that communicates with DC – ipconfig /release “adapter name”

  4. Make sure there is no ip assigned to this adapter by checking entries in HKEY_LOCAL_MACHINE\SYSTEM \CurrentControlSet \Services \Tcpip\Parameters\Interfaces (if there is, remove the entry)

  5. Shut target down.

  6. Promote disk to production.

  7. Boot new target.


Problem Cause

Statically assigned IP information on the master causes targets to try use this information and fail and will need to obtain new IP, this delay then causes group policies to fail to apply.

Issue/Introduction

   Event Type: Error Event Source: NETLOGON Event Category: None Event ID: 5719Date: DateTime: TimeUser: N/A Computer: ServerDescription:No Domain Controller is available for domain due to the following: There are currently no logon servers available to service the logon request. Make sure that the computer is connected to the network and try again. If the problem persists, contact your domain administrator.