ICA File Can't Be Launched by CDViewer for Specific User
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Article ID: CTX205993
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Updated On:
Description
- Click the XenDesktop icon on StoreFront, IE11 doesn't invoke CDViewer to get through to XenDesktop.
- Click the XenDesktop icon on StoreFront, Chrome 46.0 downloads the ICA file, clicking the downloaded ICA file doesn't invoke CDViewer to get through to XenDesktop.
User can logon to same VDA from iPad using their account. Another user logged on to the client machine with this issue, and they could log on to same VDA via StoreFront and launched CDViewer successfully.
In the past, there were other users encounter this problem, issue would disappear if they reset that user's profile.
But this time, customer doesn't want to reset user profile but wants us to find the root cause. Should relate to login/profile/registry on client machine.
Resolution
Remove contents on HKCU\Software\Citrix\ICA Client\Engine\Lockdown Profiles\, so that Receiver recreates complete keys in this path and launch ica file successfully.
Problem Cause
Customer configured the following registry keys by GPO:
HKCU\Software\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Control
ClientHostedApps
ClientHostedAppsFTAEnabled
ClientHostedAppsShortcuts
ClientHostedAppsURLEnabled
The registry keys were setup before receiver launch, so when Receiver launches, it finds out these keys then skipped other key setup, thus failed in registry verification.
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