Screensaver Not Working in XenDesktop

Screensaver Not Working in XenDesktop

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Article ID: CTX205214

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Updated On:

Description

Screensaver not starting on Virtual Desktop - Desktop OS VDA.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To enable Screen Saver for virtual desktops follow these steps: 

  1. Make the following GPO Changes:
    • Open gpedit.msc -> User Configuration -> Administrative Templates -> Control Panel -> Personalization 
      • Enable Screen saver - Set to enable 
      • Prevent changing screen saver - Set to enable 
      • Password protect screen saver- Set to enable
      • Screen saver timeout - Any Value Except 0
      • Force specific screen saver - scrnsave.scr
  2. Set the following Registry key on VDA - This must be applied to the master image. 
    • Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Graphics
    • Value Name: SetDisplayRequiredMode
    • Type: DWORD
    • Value:00000000
  3. Reboot the VDA

NOTE:

  • There is an issue that SetDisplayRequiredMode is accidentally deleted when installing VDA 1912 or later versions. (The issue is fixed as CVADHELP-17031 in 1912 LTSR CU3, CVAD 2203 Cu3 and CVAD 2305 onwards)
  • When SetDisplayRequiredMode is missing after upgrading VDA, please add it manually.
  • Make sure there is no Turn Off Display power setting is set to Never or more than the screensaver timeout value in the group policy or in the base image.

Problem Cause

Misconfigured GPO settings and missing registry key.

Note: Applying the registry change via GPO to non-persistent VDAs does not take effect as a reboot is required. The registry key must be applied to the master image.