Black Screen Appears After the Desktop Has Been Launched on XenDesktop

Black Screen Appears After the Desktop Has Been Launched on XenDesktop

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Article ID: CTX205179

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Updated On:

Description

Black Screen comes up after the desktop has been launched.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Remove the full path from the AppInit_DLLs key.

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Key Location: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Entry Name: AppInit_DLLs

Entry Type: String

New Entry Value: mfaphook64.dll

Old Entry Value: C:\Program Files\Citrix\System32\mfaphook64.dll

Key Location: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows

Entry Name: AppInit_DLLs

Entry Type: String

New Entry Value: mfaphook.dll

Old Entry Value: C:\Program Files (x86)\Citrix\System32\mfaphook64.dll


Problem Cause

Appinit_DLLs keys using the full location path.