Error: "Cannot Start App. Please contact your help desk." When Launching App Through Receiver

Error: "Cannot Start App. Please contact your help desk." When Launching App Through Receiver

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Article ID: CTX205036

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company's Help Desk/IT support team and can refer to CTX297149 for more information.

 

The following error is displayed when launching app through Receiver:
Cannot Start App. Please contact your help desk.

Event ID 31 is recorded in the event viewer.
 

Resolution

Ensure that Windows firewall is turned off on the StoreFront servers and Delivery Controllers. If completely turning off Windows server firewall is not an option, then you should use the Windows Firewall Advanced Settings to configure the rules (exceptions) for that server.

Ensure that under the Inbound Rules all the Citrix related rules are enabled. 


Problem Cause

Windows firewall was enabled on the StoreFront servers and Delivery Controllers.

Issue/Introduction

The following error is displayed when launching app through Receiver: Cannot Start App. Please contact your help desk.