XenDesktop Failed to Connect to Data Source, Broker Service Reported an Error on Event Viewer of Director Server

XenDesktop Failed to Connect to Data Source, Broker Service Reported an Error on Event Viewer of Director Server

book

Article ID: CTX204540

calendar_today

Updated On:

Description

Getting a number of issues in Eventvwr. Would like to review the issue. Failed to connect to data source The broker service reported an error on Event viewer of director server.

Resolution

1. Take snapshot of master image.
2. Repair performance counters on the master image by running the command lodctr /r and wait for the message ‘Successfully rebuilt performance counter setting from system backup store’
3. Register ICAPERF.dll by running command Regsvr32 "c:\Program Files (x86)\Citrix\System32"\icaperf.dll
4. Update the catalog, verify the ‘pending update’ shows ‘NO’ for the VDAs (studio view machines add column ‘pending update’)
5. Reboot director servers.

Problem Cause

The errors seen in event viewer are related to the failure of collecting performance data of VDAs that could be due to corrupt or missing performance counters on the VDAs, we need to repair performance counters on the VDA and register ICAPERF.DLL

Issue/Introduction

Getting a number of issues in Eventvwr. Would like to review the issue. Failed to connect to data source The broker service reported an error on Event viewer of director server