Unable To Configure Workspace Control On XenApp 7.6 Using Session Roaming

Unable To Configure Workspace Control On XenApp 7.6 Using Session Roaming

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Article ID: CTX203046

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Updated On:

Description

Issue:
Unable to launch multiple sessions for the same user from the same endpoint in XenApp & XenDesktop 7.6

Example:

User-added image
NOTE: Going straight to StoreFront (bypassing the RDP session on the Terminal Servers) works as expected.
 
History:
This functionality was configured in XenApp 6.5 by disabling Workspace Control and configuring “Override user device names”.
See: http://support.citrix.com/article/CTX123726

In 7.6 Citrix devised an experimental way for handling this use case.  In XenApp 7.7 and later, it was officially introduced and fully supported.
See: http://docs.citrix.com/en-us/xenapp-and-xendesktop/7-7/manage-deployment/sessions.html#par_anchortitle_d65d

 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution


To enable this functionality in XenApp & XenDesktop 7.6:


NOTE: While these PowerShell cmdlet’s are not officially supported in XA 7.6 , they can be tested to accomplish this functionality: 

1. Set the BrokerAppEntitlementPolcy via elevated PowerShell:

asnp citrix*

Set-BrokerAppEntitlementPolicyRule <Delivery Group Name> -SessionReconnection DisconnectedOnly
Set-BrokerAppEntitlementPolicyRule <Delivery Group Name> -SessionReconnection SameEndPointOnly


2: Allow multiple RDP sessions by setting the following GPO OR Windows registry setting:

        2.a) Using the GPO:
  • Computer Configuration\ Administrative Templates\ Windows Components\ Remote Desktop Services\ Remote Desktop Session Host\ Connections\
    • Restrict Remote Desktop Services users to a single Remote Desktop Services Session 
    • Setting = Disabled
                        User-added image


       2.b) Edit the RDS server's (server VDA's) registry:
  • Start Registry Editor (by default, this is located at c:\windows\regedit.exe).
  • Go to the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer

  • If the fSingleSessionPerUser value doesn't exist, create a new DWORD value.
  • Open the fSingleSessionPerUser value.
  • The possible values for this setting are as follows:
    0x0  = Allow multiple sessions per user
    0x1 = Force each user to a single session
  • Enter the new setting, and then click OK and reboot the server.

Problem Cause

Response from Senior Architect: "There is no support for two sessions from the same client device in 7.x. Only for the same user with different clients." 

Issue/Introduction

This article helps provide insight on how this is not a supported feature in 7.6. Used to be in XenApp 6.5

Additional Information

http://support.citrix.com/article/CTX123726

http://docs.citrix.com/en-us/xenapp-and-xendesktop/7-7/manage-deployment/sessions.html#par_anchortitle_d65d

http://remotedesktoprdp.com/force-single-session-allow-multiple-sessions-per-user