Error: "The specified network name is no longer available", Profile Fails to Load and user receives Temporary Profile if NTFS permissions changed on User Store

Error: "The specified network name is no longer available", Profile Fails to Load and user receives Temporary Profile if NTFS permissions changed on User Store

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Article ID: CTX202483

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Updated On:

Description

Under certain circumstances, a user profile may fail to load and the user receives a temporary profile. 
When this occurs an error "The specified network name is no longer available" appears in the Profile Management Log.

Environment

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Resolution

Run the attached PowerShell script to reset the NTFS permissions on UPM Store profiles.

Provide values for the following variables in the "Variables" section:

  • $homeDrivesDir
  • $domainName

Problem Cause

If NTFS permissions are changed on the profiles in the UPM Store by an administrator (for example: A migration of the UPM Store repository from one server to another, the NFTS permissions of the root folder need to be taken into consideration because of NTFS inheritance rules.) 

When users logged on copying some files/folders from the UPM Store can fail because the user had insufficient permissions to access the file/folder. If this occurs when synchronising the User's NTUSER.DAT file, the user would receive a temporary local profile.