book
Article ID: CTX201515
calendar_today
Updated On:
Description
There are no errors associated with this issue.
Users experience file transfers when saving to mapped client drives or mapped network drivers.
Users could be doing file transfers over a WAN or LAN connection.
Testing the same file transfer outside a XenApp or XenDesktop session does not show any slowness.
Resolution
Enable the
USE ASYNCHRONOUS WRITE Citrix policy.
1. Open the
Citrix Studio Console and browse to the
POLICIES node and under
Actions section click
CREATE POLICY
2. Change the 2nd drop down box to
FILE REDIRECTION this will display the
USE ASYNCHRONOUS WRITE policy under the Settings section.

3. Click the
Select link next to the
USE ASYNCHRONOUS WRITES and set this Policy to
Enabled (The default setting is disabled)

from the description you can see it is used to improve the speed of file transfers to client disks. Typically used to help speeds with file transfers over WANS but can improve LAN speeds as well.
4. Once the policy has been enabled select how it will be assigned.
- Selected user and machine objects:
- Access Control
- Citrix CloudBridge
- Client IP address
- Client Name
- Delivery Group
- Delivery Group Type
- Organizational Unit (OU)
- Tag
- User or Group
OR

5. Now name the new policy and verify the settings that are being applied and who they are assigned to.
Also make sure the checkbox
ENABLE POLICY is selected.
NOTE: You must also have the
Client drive redirection policy
enabled to use the
asynchronous writes policy
6. Now either raise the priority of this new policy to 1 or do a policy comparison to make sure there are no policy conflicts..
In the example below you can see I have compared the new policy I created name IMPROVE FILE TRANSFERS and the default UNFILTERED policy and no conflicts are seen.
Citrix DocumentationDefault Policy Settings (ICA/File Redirection section of the document)
Problem Cause
Caused by High Latency or slow network links.