Error: "FullAdmin or MachineAdmin Permission Required" in XenDesktop Setup Wizard

Error: "FullAdmin or MachineAdmin Permission Required" in XenDesktop Setup Wizard

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Article ID: CTX200899

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Description

XenDesktop setup wizard fails with permissions error.

"XenDesktop FullAdmin or MachineAdmin permission required"



 

Resolution

Perform the following checks to validate permissions:

  1. Check permissions on the DDC (in Studio) and ensure the user logged into the PVS console has the required rights(FullAdmin or MachineAdmin) in XenDekstop.

  2. Check Permissions on AD to be sure any groups listed in Studio are in the User Accounts Member tab.

  3. Check up time on DDCs is less than 30 days and restart if necessary to be sure that GPOs are applying correctly.

  4. Restart the Stream and soap on all the PVS servers.

  5. Log out and go back to the PVS server.

  6. Running CDF control should show that the Permissions error is for the user logged into the PVS Server and running console.

  7. Test by running the console as another account that (Example, Account that runs the Stream Service)

  8. Remove all the other AD groups from the user account that is failing and add back one by one.

Therefore, for the users running the PVS console have rights in XenDesktop and those rights are being recognized by the DDC and Studio, this error should not be triggered.


Problem Cause

Permissions can be denied because of misconfiguration or a competing group membership that would deny access.

Issue/Introduction

XenDesktop Setup Wizard Error : FullAdmin or MachineAdmin permission required