Error: "User does not exist" When External Users Log on to the NetScaler Using GUI or NITRO API

Error: "User does not exist" When External Users Log on to the NetScaler Using GUI or NITRO API

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Article ID: CTX200864

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Updated On:

Description

When trying to log on to the NetScaler using the GUI or the NITRO API, external users (from LDAP, TACACS, and so on) get the following error message:
"User does not exist"

When using CLI authentication works without any issues.

Resolution

To resolve this issue upgrade to NetScaler software release 10.5.52.11 or later.

Workaround

As a workaround add the user locally on NetScaler, for user authentication to work in GUI.

Problem Cause

A bug in NetScaler software build 10.5.51.10.

Issue/Introduction

Error : "User does not exist" when external users log on to the NetScaler using the GUI or the NITRO API.

Additional Information

Citrix Discussion - 10.5 build 51.10 GUI LDAP Authentication bug

Refer to issue ID 498221, 501681 in NetScaler 10.5 Build 52.11 Release Notes for more information.