Unable to Configure Receiver on Android Device Through NetScaler Gateway

Unable to Configure Receiver on Android Device Through NetScaler Gateway

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Article ID: CTX200580

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.



Unable to configure Receiver on Android device through NetScaler Gateway.

The account is added successfully through iOS and it is also accessible through Windows web browser. Session profile is configured correctly. Certificate, ns.log on NetScaler Gateway and StoreFront event viewer display no errors.

Resolution

Complete the following steps to resolve the issue:

  1. Verify if the external beacon has NetScaler Gateway FQDN. If not, define the FQDN in the external beacon and propagate the changes.

  2. Verify if load balancing virtual server for StoreFront has cookie insert persistency. Change it to sourceip.
    Now test on Android Receiver, iOS Receiver, Windows PC Receiver 4 and Windows web browser.


Problem Cause

The issue is caused by an incorrect persistency configured for load balanced virtual server on NetScaler Gateway and missing external beacon.

Issue/Introduction

Unable to configure Receiver on Android device through NetScaler Gateway.

Additional Information

CTX207162 - Error: "Cannot Complete Your Request" When Connecting to StoreFront