Printer Driver Mapping and Compatibility Policy Not Applying to Users

Printer Driver Mapping and Compatibility Policy Not Applying to Users

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Article ID: CTX200460

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Description

Printer Driver Mapping and Compatibility Policy are not being applied to users.

  • Scenario 1: User is trying to use the "Print driver mapping and compatibility" printing policy to map session printers or auto-connected network printers.
  • Scenarios 2: User is trying to use the "Print driver mapping and compatibility" printing policy to map auto-created printers. The user also has the "Driver Policy Settings" Policy set to the "Use Universal Printing Only" option.

Resolution

  • Solution for Scenario 1: The "Print Driver Mapping and Compatibility" printing policy is only for auto-created printers it cannot be used for session or auto-connected network printers. This is as designed.

  • Solution for Scenario 2: If you are auto-creating user printers but have the "Driver Policy Settings" Policy set to "Use Universal Printing Only" option, this will override the "Print Driver Mapping and Compatibility" policy and auto-create all user printers with a Citrix Universal Driver. If you want to use a Citrix Universal Driver and vendor or model specific drivers, you need to set the "Driver Policy Settings" to not configured or set it to "Use Universal Printing only if requested driver is unavailable" which is the default behavior.


Problem Cause

Caused by conflicting policy settings, or trying to use the policy not as it was designed.

Issue/Introduction

Printer driver mapping and compatibility Policy not being applied to users.

Additional Information

These settings specify the driver substitution rules for auto-created client printers.