Unable to Add Printer - Operation could not be completed (error 0x0000079)

Unable to Add Printer - Operation could not be completed (error 0x0000079)

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Article ID: CTX200364

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Updated On:

Description

With two or more print servers, a user is unable to add a printer from a non Citrix Universal Print Server(UPS). The printer is not added and displays the following error:
"Operation could not be completed (error 0x0000079). Double check the printer name and make sure that the printer is connected to the network."

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Resolution

The Policy setting Use default value: Use universal printing only if requested driver is unavailable needs to be selected by an administrator on the XenApp Server (AppCenter, DSC, Studio) or the Group Policy Management Console.


Problem Cause

When the policy Use Universal Printing Only is set and the end user attempts to add a printer from a non-UPS Print Server, the client attempts to locate the Universal Print Driver(UPD) and it fails when the UPD is not detected because the driver on the client and server do not match.

Issue/Introduction

Unable to Add Printer - Operation could not be completed (error 0x0000079)

Additional Information

Citrix Documentation - Universal Printing Policy Settings