Unsupported SFPs Message in the Log File of NetScaler Appliance

Unsupported SFPs Message in the Log File of NetScaler Appliance

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Article ID: CTX200297

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Updated On:

Description

Some Citrix branded 10-Gigabit small form-factor (SFP+) transceivers fail to be registered by NetScaler MPX and SDX appliances. 

The following messages are seen in the serial console and the console log file of the NetScaler appliance:
"FP+/SFP, vendor CITRIX, part number FTLX8571D3BCVCTX, 10G 0X10 1G 0X0 CT 0X00
*** Unsupported SFP+/SFP type !
"

The error messages are seen when the NetScaler appliance boots. This is shown by the text highlighted in Red in the following screen shot:

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Resolution

The malfunctioning parts should be replaced. Contact Citrix technical support team to initiate the Returns of Merchandise Authorization (RMA) process for a replacement part.

To identify the good and bad parts, refer to the following images. The good part is Citrix branded and includes printed (Image 1) or hand-written (Image 2) text "A2" revision on the label.

Image 1: Good Part

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Image 2: Good Parts

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Image 3: Bad Part
The bad part that needs to be replaced is also Citrix branded but does not have the "A2" revision designation on the label (Image 3). This part will have to be replaced.

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If you have one of these parts, then contact the Citrix technical support team to initiate the RMA process to have the problem transceivers replaced.

Note: If you have a non-Citrix part then you do not have to take any action as that part will function normally.


Problem Cause

This issue is caused by bad code on the SFP.  When the NetScaler boots up and performs the hardware check, the transceivers are not recognized as supported and the error(s) are recorded in the serial console and console log file.

Issue/Introduction

Few Citrix 10G transceivers generate "*** Unsupported SFP+/SFP type !" message in the log file of NetScaler appliance.