DNS Resolution through NetScaler Fails with Unknown Host Error

DNS Resolution through NetScaler Fails with Unknown Host Error

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Article ID: CTX200232

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Updated On:

Description

DNS resolution for FQDN fails and following error is received when pinging FQDN from NetScaler:

VPX-190> ping www.citrix.com
ping: cannot resolve www.citrix.com: Unknown host
ERROR:

Resolution

Complete the following procedure:

  1. Verify the configuration and find if the SOA record is configured for the root server which is not required.
    add dns soaRec . -originServer a.root-servers.net –contact <xxxxxxx>

  2. Remove the preceding SOA record and flush the stored proxy records. After removing SOA records, the resolution works.
>rm dns soaRec .
>flush dns proxyrecords
 

Note: Where <xxxxxxx>  is the Email address of the contact to whom domain issues can be addressed. In the email address, replace the @ sign with a period (.). For example, enter domainadmin.example.com instead of domainadmin@example.com.


Problem Cause

When a ping request is done on NetScaler, the request is sent internally to nameserver 127.0.0.2.
While resolving the request, check if an authentic NetScaler record for the parent domain is present.
If both NS record and SOA records are present for the same parent domain, NS serves nxdomain/nodata response authoritatively.
In this case, the root ns records are added by default, and adding SOA records for root manually causes the issue.

Issue/Introduction

DNS resolution fails ​and the following error is received when pinging FQDN from NetScaler.