Failure to Store Cache on Local Hard Drive

Failure to Store Cache on Local Hard Drive

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Article ID: CTX140448

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Updated On:

Description

Even after selecting “cache is on device hard drive”, cache is getting stored on the Provisioning Service (PVS) server. The following screen shot shows the virtual disk status:

User-added image

Environment

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Resolution

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

Complete the following steps to fix the issue:

  1. Validate the write cache disk is formatted with NTFS.

  2. Partition created is using MBR and not GPT disk partitioning (PVS does not support GPT).

  3. Ensure that the minimum amount of free space on the local drive is 500MB.

  4. In case multiple drives are attached on the target, remove the drives to validate if the behavior still occurs.

  5. For Windows 2012 targets devices, update the registry keys:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BNIStack\parameters
    DWORD WcHDInitRetryNumber: default 150, up to 200
    DWORD WcHDInitRetryIntervalMs: default 100ms, up to 500ms


Problem Cause

The following are some scenarios that cause the cache to redirect to the PVS server:

  • Improper formatting of the write cache drive.

  • Drive not meeting the minimum required size.

  • Windows 2012 target devices appear to take a longer time to initialize the disk and bnistack.

    Issue/Introduction

    Even after selecting “cache is on device hard drive”, cache is getting stored on the Provisioning Service (PVS) server.