Citrix Desktop Service Will Not Start or Restart After Installing .NET Based Applications on 64-Bit Windows Platforms

Citrix Desktop Service Will Not Start or Restart After Installing .NET Based Applications on 64-Bit Windows Platforms

book

Article ID: CTX140116

calendar_today

Updated On:

Description

The Citrix Desktop Services does not start or restart when certain .NET based applications are installed on the Windows x64 master image used to create desktops.

Background

Installation of the .NET based software results in the failure of the Citrix Desktop services to start or restart.
Installation of the .NET based software results in the failure of the Citrix Desktop services to start or restart

The Application Event Log of the VDA machine might also show Event ID 1006:
"The Citrix Desktop Service failed to start.
If this problem persists, reinstall the Citrix Virtual Desktop Agent."
See CTX126990 - Troubleshooting XenDesktop Service Startup Issues.

The Citrix Desktop Service failed to start. If this problem persists, reinstall the Citrix Virtual Desktop Agent. See Citrix Knowledge Base Article CTX119736

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Complete the following procedure to fix the .NetworkFramework value:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor. 

  1. Open the registry editor by completing the following procedure:

    1. Go to Start > Run.
    2. Type regedit to open the Registry Editor.
  2. Locate HKLM\Software\Microsoft\.NETFramework.

  1. Check if DWORD value Enable64bit exists and is set to data 0.

  2. If this value is set to 0, then set the value to 1 by completing the following procedure:

    1. Double-click this value and set this value to 1 (decimal) or 0x1 (hexadecimal).

    2. Click OK.
      Double-click on this value and set this value 1 (decimal) or 0x1 (hexadecimal).

  3. Restart the VDA machine.
    When the machine restarts, verify that the Citrix Desktop Service starts or restarts.
    Restart the VDA machine


Problem Cause

Citrix Desktop Services for XenDesktop uses the 64-bit version of .NET Framework. Enabling the 64-bit version is controlled by a registry key named Enable64Bit, located in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework.
This key is set to a value of 0 by the third-party application installers to use the 32-bit framework version.
Note: Uninstalling the third party software might not revert the registry value to 1.

Issue/Introduction

The installation of .Net based applications that impact the Enable64Bit (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework) registry key prevents Citrix Desktop Services from starting or restarting.