Users Connecting to Delivery Groups Receive a 'Cannot Start Desktop' Error

Users Connecting to Delivery Groups Receive a 'Cannot Start Desktop' Error

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Article ID: CTX138934

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Updated On:

Description

Users connecting to delivery groups receive a ‘cannot start desktop’ error.

Background

In the Windows application event logs on the Delivery Controller(s), the following errors appear:

Event ID: 1101
Source: Citrix Broker Service
Level: Warning

The Citrix Broker Service failed to broker a connection for user 'domain\username' to resource 'Delivery Group'. The Citrix Broker Service cannot find any available virtual machines.

Please add more virtual machines to the site. If the problem is due to existing virtual machines not becoming available, see Citrix Knowledge Base article CTX126992. - Note: Placing the desktops into Maintenance mode and removing them from Maintenance mode resolves the above issue

Resolution

Follow the steps mentioned in CTX134190 - Users Cannot Connect To Desktops Flagged with Hidden 'WillshutdownAfterUse' Parameter as a workaround.


Problem Cause

This occurs because desktops in the delivery group configured to shut down after use did not shut down, possibly because of a power action that did not reach the hypervisor. These ‘tainted’ desktops are not available for use until they are restarted.

Issue/Introduction

Users are unable to connect to specific delivery groups. A connection brokering error (Event ID 1101) appears in the Windows Application event logs on the Delivery Controller(s).

Additional Information

CTX134190 - Users Cannot Connect To Desktops Flagged with Hidden 'WillshutdownAfterUse' Parameter