Blue Screen Appears After Updating a vDisk with Personal vDisk Enabled

Blue Screen Appears After Updating a vDisk with Personal vDisk Enabled

book

Article ID: CTX138350

calendar_today

Updated On:

Description

After updating a vDisk that has Personal vDisk enabled, a blue screen (BSOD) appears with a STOP c0000102 error indicating a corrupt file: 

User-added image

Note: Detaching the personal vDisk from the virtual machine allows it to start.

Resolution

Complete the following steps to fix the issue:
  1. Mount the UserData.V2.vhd file on the Personal vDisk as a drive in Disk Management and run chkdsk against it.
Important: The personal vDisk must not be in use. You can start the corrupt Virtual Machine in Safe Mode and mount the VHD file, or you can mount it to another Windows 7 or Windows 2008-based Virtual Machine.
  1. To mount the VHD, open Disk Management in Windows 7 or 2008 (Action > Attach VHD): 
User-added image
  1. Browse to the UserData.v2.vhd file and mount it.
Note: There are also third-party utilities that will mount VHD files.
  1. When the VHD is mounted as a drive letter, run chkdsk using one of the following methods: 

Graphically

  1. Right-click on the drive in Explorer, click Tools, then Check now….
  2. Ensure that the Automatically fix file system errors is selected.

    Note: Do not select Scan for and attempt recovery of bad sectors.
  3. Click Start.

    User-added image

Command Line

  1. Open Command Prompt (Start > Run > cmd or All Programs > Accessories > Command Prompt).
  2. Run the command chkdsk /f [driveletter].

    For example, if you mounted the Personal vDisk as drive E:, run chkdsk /f e:.
  3. After the chkdsk completes, unmount the VHD and attempt to start the target device again.


Problem Cause

There are corrupt files or directories on the Personal vDisk.

Issue/Introduction

After updating a vDisk that has Personal vDisk enabled, a Blue Screen (BSoD) appears with a STOP error indicating a corrupt file.