XenApp Policies Configured through GPO are not Applied on the XenApp Servers

XenApp Policies Configured through GPO are not Applied on the XenApp Servers

book

Article ID: CTX138309

calendar_today

Updated On:

Description

All the configured XenApp policies through GPO are not applied on the XenApp Servers.

The settings configured through GPO along with the installed XenApp group policy extensions are not listed in the following registry:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor.

HKEY_LOCAL_MACHINE\Software\Wow6432Node\Citrix

Other policies (System Operating policies) are applied correctly.

The event log does not show any issues within the GPO application process. When capturing the Client Side Extension (CSE) logs, the GPO can be seen in CSE Client log but not in the CSE Engine log.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve the issue, either include the Authenticated Users group in the ACL of GPO, or apply the Microsoft KB hotfix 2553771.


Problem Cause

The GPO is not applied because the Authenticated Users group is not in the Access Control List (ACL) of the GPO.

Issue/Introduction

This article provides a resolution for the issue of XenApp policies configured through GPO are not applied on the XenApp Servers.