Using Veeam Backup Software on Provisioning Services Server

Using Veeam Backup Software on Provisioning Services Server

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Article ID: CTX137817

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Updated On:

Description

While running Veeam software to backup Provisioning Services (PVS) servers, one of the PVS servers display status as Down in PVS server console regardless of whether the stream service is running.

The following screen shot shows the server status in PVS console.

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The following screen shot shows the stream service status for the server which is Down.

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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

To resolve this issue, complete the following procedure:

Caution! Refer to the Disclaimer at the end of this article before using Registry Editor. 

  1. Increase the connection timeout.

  2. Create a registry of message timeout for IPC as follows and assign the value as twice the time for which the Veeam process is scheduled:

    HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ProvisioningServices\IPC
    Registry entry: MsgTimeout
    Data type: DWORD
    Value: 600


Problem Cause

Veeam interferes with the communication of a PVS for few minutes during snapshot. The stream process cannot log data. During this same time period, target device cannot connect to the problem PVS Server. Restarting stream process restarts the active connections to the PVS.

Issue/Introduction

While running Veeam software to backup Provisioning Services (PVS) servers, one of the PVS servers display status as Down in PVS server console regardless of whether the stream service is running.