XenApp 5.0 - Error: "Cannot Connect to the Citrix XenApp Server. Protocol Driver Error."

XenApp 5.0 - Error: "Cannot Connect to the Citrix XenApp Server. Protocol Driver Error."

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Article ID: CTX136826

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Updated On:

Description

When attempting to launch an application server, the following error message is displayed:

"Unable to launch your application. Contact your help desk with the following information: Cannot connect to the Citrix XenApp server. Protocol Driver error."

No ICA sessions can be established to the server.

Resolution

Solution 1

Complete the following steps on the server to recreate the ICA Listener:

  1. Open the Microsoft Management Console (MMC) Terminal Services Configuration (TsConfig.msc) , right-click the ICA-tcp listener, and click Delete. Click Yes.

  2. Expand the Action menu and click Create New Connection. Click Next.

  3. Continue through the wizard and configure the desired settings. When the option to name the listener appears, type ICA-tcp in the Name field.

  4. Click Next and then click Finish.

  5. Right click ICA-tcp listener and click Properties.

  6. Select the Permissions tab and add the local account ctx_cpsvcuser.

  7. Edit the advanced permissions and select only the Query Information and Virtual Channels check boxes under the Allow column.

  8. Click OK and close the MMC.

  9. Restart the Print Spooler and Citrix Print Manager services.

Solution 2

Remove App Controller as STA from NetScaler and StoreFront.

Solution 3

Ensure that ports 1494 and 2598 between the NetScaler and the app server is open.

 

Problem Cause

Session Reliability is enabled in the environment and it is unable to contact the ICA Listener. The ICA Listener is no longer functioning and must be recreated. To confirm this, check the following:

  • From the Command Prompt, run the command netstat -a. The TCP port 2598 (Session Reliability) is LISTENING but TCP port 1494 (ICA) is not displayed in the list.
  • Examine the XTE logs at "C:\Program Files (x86)\Citrix\XTE\logs\error.log". The message "Unable to connect to the CGP tunnel destination (127.0.0.1:1494)" is repeated.

Issue/Introduction

This article provides steps to resolve Error: "Cannot Connect to the Citrix XenApp Server. Protocol Driver Error." for XenApp 5.0

Additional Information