Mac Receiver Launches Application and Closes Abruptly

Mac Receiver Launches Application and Closes Abruptly

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Article ID: CTX136343

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only. Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.
 

User is unable to log on from a MacBook using the Citrix Receiver for Mac. The session opens and eventually disappears without any error message. 

Resolution

To resolve this issue, complete the following steps:

  1. Select the System Preferences icon on the toolbar.

    User-added image

  2. Open the Sharing folder in System Preferences under Internet & Wireless, as displayed in the following screen shot:

    User-added image

  1. Check the Computer Name field. If it is blank, type a computer name for the machine so that a license can be assigned to it.

    User-added image

The session opens successfully from a MacBook using Citrix Receiver for Mac.


Problem Cause

Because the Mac devices does not have a registry like Windows devices, a license must be issued to the client devices name. If the device does not have a name, it cannot be issued a license. It attempts to assign a license to a null value, and the session drops.

Issue/Introduction

This article provides a resolution to the issue where Mac Receiver will not launch application or launches application and then closes.