Profile Streaming Stops Working After Restarting Server

Profile Streaming Stops Working After Restarting Server

book

Article ID: CTX136024

calendar_today

Updated On:

Description

Profile streaming is enabled in the UPM policy. However, it does not work after the server restarts and the ICA logon time to a XenApp server is slow.

Profile streaming starts working after restarting the Profile Manager service. If a user then logs on to the XenApp server in an ICA session, the logon time is much faster.

Resolution

Use the following artciles to apply Version 4.1.2 of User Profile Manager.

Problem Cause

The issue can be observed in the UPM log files.

Immediately after a restart, the log files for a user logon show the following:
2012-10-17;09:38:46.171;INFORMATION;DOMAIN_NAME;username;3;1684;Checking JIT availability:... 2012-10-
17;09:38:46.234;INFORMATION;DOMAIN_NAME;username;3;1684;Loaded profile streaming driver 2012-10-
17;09:38:46.234;INFORMATION;DOMAIN_NAME;username;3;1684;Streaming driver load check completed 2012-10
-17;09:38:46.234;INFORMATION;DOMAIN_NAME;username;3;1684;Streaming driver is NOT AVAILABLE. Supported version = 0

After the Citrix Profile Manager Service restarts, the user logon time is quicker and the following is shown in the logs:
2012-10-17;09:40:30.702;INFORMATION;DOMAIN_NAME;username;4;9564;Checking JIT availability:... 2012-10-
17;09:40:30.718;INFORMATION;DOMAIN_NAME;username;4;9564;Streaming driver is AVAILABLE. Supported version = 2

Issue/Introduction

This artilce provides resolution when Profile Streaming stops working after restarting the server.