Error: "An error occurred during synchronization" in StoreFront

Error: "An error occurred during synchronization" in StoreFront

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Article ID: CTX135725

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Updated On:

Description

When trying to synchronize changes on a StoreFront multi-server environment, the following errors are displayed:

Error: “An error occurred during synchronization”

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You might also view errors in the StoreFront Server Console > Server Group.

Error: “Cannot get valid synchronization state information. Please refer to Windows Event Viewer for details.”

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Resolution

Scenario - 1

Complete the following steps on Primary StoreFront Server:

  1. Close StoreFront Console.

    Citrix Configuration Replication Service is stopped.

  2. Open Services and Start Service on the Primary Storefront Server.

The following screen shot shows the Service as not running:

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The following screen shot shows Service as running:

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  1. Open StoreFront Console.

  2. Select Server Group.

  3. Select Sync Settings with Server Group.

  4. Click OK to the message “Do you want to sync “server name” with the server group?”.

    The Sync will be completed.

Scenario - 2

Complete the following steps on Secondary StoreFront Server:

  1. Citrix Configuration Replication Service is stopped. Open Services and start Service on the Primary StoreFront Server.

  2. Open Primary StoreFront Server and start StoreFront Console.

  3. Select Server Group.

  4. Select Sync Settings with Server Group.

  5. Click OK to the message “Do you want to sync “server name” with the server group?”

  6. Sync completes.


Problem Cause

StoreFront cannot perform a successful synchronization between the StoreFront Servers Group. The service, which handles the replication is stopped. Errors will be logged inside Event Viewer > Citrix Delivery Services.

Following are the detailed information about the errors:

Scenario - 1

Error occurs on Primary StoreFront Server:

Three errors will be logged in Citrix Delivery Services Logs (Event ID 0, another Event ID 0 and a third one Event ID 1 with task Category 2850).

Following are the screenshots of the error messages displayed:

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Error - 1

Event ID 0 Task Category: None

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Error - 2

Event ID 0 Task Category: None

Note: It is a replica of the first error.

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Error - 3

Event ID Task Category: 2580

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When there is an error on Primary server, the event logs shows the URL http://localhost/Citrix/DeliveryServices/ConfigurationReplication.

Using this, you can determine the problem which is related to the Primary Server pushing all StoreFront changes/Settings/Replication.

Scenario - 2

Issue can also be observed when replication service is not working on a remote Server. The Primary StoreFront Server also throws errors.

  • There will be 3 errors displayed at the Primary StoreFront Server (Event ID 0, Event ID 1 task category 2580, and Event ID 19 task Category 2801).
  • Event ID 0 and Event ID 1 indicates which server from the StoreFront Server Group is having the issue. This can be found in line (The HTTP service located at http://servername/Citrix/Delivery/Services/ConfigurationReplication)
Following are the screenshots of the errors:

    Error - 1

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    Error - 2

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    Error - 3

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    Note: Server 1 is unable to get sync update to Server 2 because replication on Server 2 is not reachable.

    Issue/Introduction

    Errors observed when tring to push Sync updates between StoreFront Servers when running on a multi-server environment.